The 502 Bad Gateway Error means that that our network is unable to communicate with your server. This could occur for two potential issues:

  1. Change of the Origin IP:
    If you change hosts, move to a dedicated IP Address, started using a Load Balancer, CloudFlare, or just change your IP address for any reason, CDN will stop functioning and you will encounter a 502 Bad Gateway Error. In this case, you need to update the Origin IP in the NetDNA/MaxCDN/CloudCache Pull Zone configuration to match the new IP.
  2. Firewall blocking our servers:
    As a part of the DDoS mitigation process, or as a result of some strict firewall rules, our servers can be blocked from accessing the origin web server to pull out the files. In this case, you just need to white-list our Subnets in your Firewall rules.

What do I do when I get the 502 Error?

The first thing to do when you get the 502 error is to check your origin IP in the zone management, click on “Settings” and make sure the IP address is correct. Should it be found incorrect, you need to update the Origin IP in the NetDNA/MaxCDN/CloudCache Pull Zone configuration to match the new IP, purge your zone cache, and try again. This should fix the problem.

If the IP address is correct, please check your firewall rules and make sure you white-list our subnets.

If the problem persists, please send an email to Support and our team will work to fix the issue.