Help, when I view files from my Pull Zone, I get a 502 Error. Why?
The 502 (Gateway error) is not a very common error, and it occurs in 3 rare occasions.
- IP On the backend changed:
If you changed your hosting provider, your website’s IP address will definitelly change. In this case, you will need to manually update the IP address of the origin website of your Pull Zone from the “settings” tab in order for your Pull Zone to function properly, otherwise it will return a 502 error.
- Firewall blocking our servers:
As a part of the DDoS mitigation process, or as a result of some strict firewall rules, our servers can be blocked from accessing the origin web server to pull out the files. In this case, you just need to white-list our Subnets in your Firewall rules.
- Bad/Corrupt Provisioning:
This is the last and most unusual case, and it happens very rarely when something goes wrong during provisioning. Our support will be able to solve the problem by re-provisioning your Pull Zone.
What do I do when I get the 502 Error?
The first thing to do when you get the 502 error is to check your origin IP in the zone management, click on “Settings” and make sure the IP address is correct. Should it be found incorrect, edit it to use the correct IP address, purge your zone cache, and try again. This should fix the problem.
If the IP address is correct, please check your firewall rules and make sure you whitelist our subnets.
If the problem persists, please send an email to Support and our team will manage to fix the issue.
|