Today we present 2.12, and its successor, the superior 2.12.1.
There have been plenty of questions about full sites as custom domains, and this launch addresses that with a spiffy FAQ.
The API plays nice now, after a scolding, and no longer mouths off with NULL.
We also had a little chat with Cache Inspector and listZones to clear the air.
Technical details below:
IMPROVEMENTS
- Custom Domains
Added FAQ for custom domains: We don´t allow full sites as custom domains, which means www or a url like http://example.com are not valid as custom domain - Improved Custom Domain error message
BUG FIXES
- API
Fixed an API issue that occurs when NULL values exist in return array: The PHP XML-RPC client does not allow NULL values. Our API does, as with this release, not return NULL values anymore. - listZones
Fixed beginning 0 value & removed array wrapper for listZones functions: listZones function returns zones now in a proper array - Cache Inspector
Fixed Cache Inspector validation error: A input validation error was fixed.
Tags: API, cache inspector, custom domains, FAQ, listZones
This entry was posted on Friday, July 22nd, 2011 at 6:27 pm and is filed under API, Control Panel, News. You can follow any responses to this entry through the RSS 2.0 feed. You can leave a response, or trackback from your own site.
Blog